Visualization package

Mar 15, 2011 at 3:50 PM

Hi Alexander,

I wanted to ask you a favor. Could you, please, add one more package type -- corechart. For some reason, some configuration options do work properly with barchart package, but Ok with corechart, that includes barchart, piechart, etc. Even Google provides sample using corechart package: http://code.google.com/apis/visualization/documentation/gallery/barchart.html#Example There is potential problem using different packages at same time, but it is up to user. Google says: "Warning: You cannot load both barchart and corechart packages at the same time on the same page."

Because enumiration VisualizationPackage used in two places, probably second parameter is needed.

Thank you.

Mar 15, 2011 at 4:04 PM

Hi.

I not longer support this project, but it is opensource, if you need you can add new feature, then send me a patch and i share it at sources

Thanks.

Mar 15, 2011 at 7:54 PM
Edited Mar 15, 2011 at 9:05 PM

I made request to Google about this issue, below is their response at: http://code.google.com/p/google-visualization-api-issues/issues/detail?id=549

 

Yes, this is known and by design. The corechart package replaces the old barchart package (and friends).
The documentation for the new corechart BarChart is at http://code.google.com/apis/visualization/documentation/gallery/barchart.html
and the documentation for the old barchart BarChart is at http://code.google.com/apis/visualization/documentation/gallery/barchart_old.html
(and can be accessed via the corechart docs). The docs for each specifies the available options for each.